Diameter

The Diameter protocol

Diameter RFCs (47)

Display RFCs as
  • RFC 9390: Diameter Group Signaling

    Proposed Standard
  • RFC 8581: Diameter Agent Overload and the Peer Overload Report

    Proposed Standard
  • RFC 8582: Diameter Overload Rate Control

    Proposed Standard
  • RFC 8583: Diameter Load Information Conveyance

    Proposed Standard
  • RFC 8506: Diameter Credit-Control Application

    Proposed Standard
  • RFC 7966: Security at the Attribute-Value Pair (AVP) Level for Non-neighboring Diameter Nodes: Scenarios and Requirements

    Informational
  • RFC 7944: Diameter Routing Message Priority

    Proposed Standard
  • RFC 7831: Application Bridging for Federated Access Beyond Web (ABFAB) Architecture

    Informational
  • RFC 7832: Application Bridging for Federated Access Beyond Web (ABFAB) Use Cases

    Informational
  • RFC 7683: Diameter Overload Indication Conveyance

    Proposed Standard
  • RFC 7678: Attribute-Value Pairs for Provisioning Customer Equipment Supporting IPv4-Over-IPv6 Transitional Solutions

    Proposed Standard
  • RFC 7660: Diameter Congestion and Filter Attributes

    Proposed Standard
  • RFC 7423: BCP 193: Diameter Applications Design Guidelines

    Best Current Practice
  • RFC 7155: Diameter Network Access Server Application

    Proposed Standard
  • RFC 7156: Diameter Support for Proxy Mobile IPv6 Localized Routing

    Proposed Standard
  • RFC 7075: Realm-Based Redirection In Diameter

    Proposed Standard
  • RFC 7068: Diameter Overload Control Requirements

    Informational
  • RFC 6942: Diameter Support for the EAP Re-authentication Protocol (ERP)

    Proposed Standard
  • RFC 6733: Diameter Base Protocol

    Proposed Standard
  • RFC 6734: Diameter Attribute-Value Pairs for Cryptographic Key Transport

    Proposed Standard
  • RFC 6735: Diameter Priority Attribute-Value Pairs

    Proposed Standard
  • RFC 6736: Diameter Network Address and Port Translation Control Application

    Proposed Standard
  • RFC 6737: The Diameter Capabilities Update Application

    Proposed Standard
  • RFC 6738: Diameter IKEv2 SK: Using Shared Keys to Support Interaction between IKEv2 Servers and Diameter Servers

    Proposed Standard
  • RFC 6408: Diameter Straightforward-Naming Authority Pointer (S-NAPTR) Usage

    Proposed Standard
  • RFC 6159: Session-Specific Explicit Diameter Request Routing

    Informational
  • RFC 5866: Diameter Quality-of-Service Application

    Proposed Standard
  • RFC 5779: Diameter Proxy Mobile IPv6: Mobile Access Gateway and Local Mobility Anchor Interaction with Diameter Server

    Proposed Standard
  • RFC 5778: Diameter Mobile IPv6: Support for Home Agent to Diameter Server Interaction

    Proposed Standard
  • RFC 5777: Traffic Classification and Quality of Service (QoS) Attributes for Diameter

    Proposed Standard
  • RFC 5719: Updated IANA Considerations for Diameter Command Code Allocations

    Proposed Standard

      Obsoleted by RFC 6733

  • RFC 5729: Clarifications on the Routing of Diameter Requests Based on the Username and the Realm

    Proposed Standard
  • RFC 5624: Quality of Service Parameters for Usage with Diameter

    Proposed Standard
  • RFC 5580: Carrying Location Objects in RADIUS and Diameter

    Proposed Standard
  • RFC 5516: Diameter Command Code Registration for the Third Generation Partnership Project (3GPP) Evolved Packet System (EPS)

    Informational
  • RFC 5431: Diameter ITU-T Rw Policy Enforcement Interface Application

    Informational
  • RFC 5447: Diameter Mobile IPv6: Support for Network Access Server to Diameter Server Interaction

    Proposed Standard
  • RFC 5224: Diameter Policy Processing Application

    Informational
  • RFC 4818: RADIUS Delegated-IPv6-Prefix Attribute

    Proposed Standard
  • RFC 4740: Diameter Session Initiation Protocol (SIP) Application

    Proposed Standard
  • RFC 4072: Diameter Extensible Authentication Protocol (EAP) Application

    Proposed Standard
  • RFC 4006: Diameter Credit-Control Application

    Proposed Standard

      Obsoleted by RFC 8506

  • RFC 4004: Diameter Mobile IPv4 Application

    Proposed Standard
  • RFC 4005: Diameter Network Access Server Application

    Proposed Standard

      Obsoleted by RFC 7155

  • RFC 4097: Middlebox Communications (MIDCOM) Protocol Evaluation

    Informational
  • RFC 3588: Diameter Base Protocol

    Proposed Standard

      Obsoleted by RFC 6733

  • RFC 3589: Diameter Command Codes for Third Generation Partnership Project (3GPP) Release 5

    Informational

Subscribe to Diameter

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.