IDN

IDN (Internationalized Domain Names): IDNA, punycode, label validity

IDN RFCs (24)

Display RFCs as
  • RFC 9224: STD 95: Finding the Authoritative Registration Data Access Protocol (RDAP) Service

    Internet Standard
  • RFC 9233: Internationalized Domain Names for Applications 2008 (IDNA2008) and Unicode 12.0.0

    Proposed Standard
  • RFC 9095: Extensible Provisioning Protocol (EPP) Domain Name Mapping Extension for Strict Bundling Registration

    Informational
  • RFC 8753: Internationalized Domain Names for Applications (IDNA) Review for New Unicode Versions

    Proposed Standard
  • RFC 8228: Guidance on Designing Label Generation Rulesets (LGRs) Supporting Variant Labels

    Informational
  • RFC 7940: Representing Label Generation Rulesets Using XML

    Proposed Standard
  • RFC 7484: Finding the Authoritative Registration Data (RDAP) Service

    Proposed Standard

      Obsoleted by RFC 9224

  • RFC 6855: IMAP Support for UTF-8

    Proposed Standard

      Obsoleted by RFC 9755

  • RFC 6797: HTTP Strict Transport Security (HSTS)

    Proposed Standard
  • RFC 6452: The Unicode Code Points and Internationalized Domain Names for Applications (IDNA) - Unicode 6.0

    Proposed Standard
  • RFC 6055: IAB Thoughts on Encodings for Internationalized Domain Names

    Informational
  • RFC 5992: Internationalized Domain Names Registration and Administration Guidelines for European Languages Using Cyrillic

    Informational
  • RFC 5895: Mapping Characters for Internationalized Domain Names in Applications (IDNA) 2008

    Informational
  • RFC 5890: Internationalized Domain Names for Applications (IDNA): Definitions and Document Framework

    Proposed Standard
  • RFC 5891: Internationalized Domain Names in Applications (IDNA): Protocol

    Proposed Standard
  • RFC 5892: The Unicode Code Points and Internationalized Domain Names for Applications (IDNA)

    Proposed Standard
  • RFC 5893: Right-to-Left Scripts for Internationalized Domain Names for Applications (IDNA)

    Proposed Standard
  • RFC 5894: Internationalized Domain Names for Applications (IDNA): Background, Explanation, and Rationale

    Informational
  • RFC 4690: Review and Recommendations for Internationalized Domain Names (IDNs)

    Informational
  • RFC 4290: Suggested Practices for Registration of Internationalized Domain Names (IDN)

    Informational
  • RFC 3743: Joint Engineering Team (JET) Guidelines for Internationalized Domain Names (IDN) Registration and Administration for Chinese, Japanese, and Korean

    Informational
  • RFC 3490: Internationalizing Domain Names in Applications (IDNA)

    Proposed Standard

      Obsoleted by RFC 5890, RFC 5891

  • RFC 3491: Nameprep: A Stringprep Profile for Internationalized Domain Names (IDN)

    Proposed Standard

      Obsoleted by RFC 5891

  • RFC 3492: Punycode: A Bootstring encoding of Unicode for Internationalized Domain Names in Applications (IDNA)

    Proposed Standard

Subscribe to IDN

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.