POP3
POP3 (Post Office Protocol version 3)
Within this page
POP3 RFCs (27)
RFC 8314: Cleartext Considered Obsolete: Use of Transport Layer Security (TLS) for Email Submission and Access
Proposed Standard- K. Moore
- C. Newman
- January 2018
- IETF publication
- Security Area
Abstract
This specification outlines current recommendations for the use of Transport Layer Security (TLS) to provide confidentiality of email traffic between a Mail User Agent (MUA) and a Mail Submission Server or Mail Access Server. This document updates RFCs 1939, 2595, 3501, 5068, 6186, and 6409.
Abstract
This specification outlines current recommendations for the use of Transport Layer Security (TLS) to provide confidentiality of email traffic between a Mail User Agent (MUA) and a Mail Submission Server or Mail Access Server. This document updates RFCs 1939, 2595, 3501, 5068, 6186, and 6409.
RFC 7817: Updated Transport Layer Security (TLS) Server Identity Check Procedure for Email-Related Protocols
Proposed Standard- A. Melnikov
- March 2016
- IETF publication
- Security Area
Abstract
This document describes the Transport Layer Security (TLS) server identity verification procedure for SMTP Submission, IMAP, POP, and ManageSieve clients. It replaces Section 2.4 (Server Identity Check) of RFC 2595 and updates Section 4.1 (Processing After the STARTTLS Command) of RFC 3207, Section 11.1 (STARTTLS Security Considerations) of RFC 3501, and Section 2.2.1 (Server Identity Check) of RFC 5804.
Abstract
This document describes the Transport Layer Security (TLS) server identity verification procedure for SMTP Submission, IMAP, POP, and ManageSieve clients. It replaces Section 2.4 (Server Identity Check) of RFC 2595 and updates Section 4.1 (Processing After the STARTTLS Command) of RFC 3207, Section 11.1 (STARTTLS Security Considerations) of RFC 3501, and Section 2.2.1 (Server Identity Check) of RFC 5804.
RFC 7636: Proof Key for Code Exchange by OAuth Public Clients
Proposed Standard- N. Sakimura
- J. Bradley
- N. Agarwal
- September 2015
- IETF publication
- Security Area
Abstract
OAuth 2.0 public clients utilizing the Authorization Code Grant are susceptible to the authorization code interception attack. This specification describes the attack as well as a technique to mitigate against the threat through the use of Proof Key for Code Exchange (PKCE, pronounced "pixy").
Abstract
OAuth 2.0 public clients utilizing the Authorization Code Grant are susceptible to the authorization code interception attack. This specification describes the attack as well as a technique to mitigate against the threat through the use of Proof Key for Code Exchange (PKCE, pronounced "pixy").
RFC 6955: Diffie-Hellman Proof-of-Possession Algorithms
Proposed Standard- J. Schaad
- H. Prafullchandra
- May 2013
- IETF publication
Abstract
This document describes two methods for producing an integrity check value from a Diffie-Hellman key pair and one method for producing an integrity check value from an Elliptic Curve key pair. This behavior is needed for such operations as creating the signature of a Public-Key Cryptography Standards (PKCS) #10 Certification Request. These algorithms are designed to provide a Proof-of-Possession of the private key and not to be a general purpose signing algorithm.
This document obsoletes RFC 2875.
Abstract
This document describes two methods for producing an integrity check value from a Diffie-Hellman key pair and one method for producing an integrity check value from an Elliptic Curve key pair. This behavior is needed for such operations as creating the signature of a Public-Key Cryptography Standards (PKCS) #10 Certification Request. These algorithms are designed to provide a Proof-of-Possession of the private key and not to be a general purpose signing algorithm.
This document obsoletes RFC 2875.
RFC 6856: Post Office Protocol Version 3 (POP3) Support for UTF-8
Proposed Standard- R. Gellens
- C. Newman
- J. Yao
- K. Fujiwara
- March 2013
- IETF publication
- Applications Area
Abstract
This specification extends the Post Office Protocol version 3 (POP3) to support international strings encoded in UTF-8 in usernames, passwords, mail addresses, message headers, and protocol-level text strings.
Abstract
This specification extends the Post Office Protocol version 3 (POP3) to support international strings encoded in UTF-8 in usernames, passwords, mail addresses, message headers, and protocol-level text strings.
RFC 6858: Simplified POP and IMAP Downgrading for Internationalized Email
Proposed Standard- A. Gulbrandsen
- March 2013
- IETF publication
- Applications Area
Abstract
This document specifies a method for IMAP and POP servers to serve internationalized messages to conventional clients. The specification is simple, easy to implement, and provides only rudimentary results.
Abstract
This document specifies a method for IMAP and POP servers to serve internationalized messages to conventional clients. The specification is simple, easy to implement, and provides only rudimentary results.
RFC 6186: Use of SRV Records for Locating Email Submission/Access Services
Proposed Standard- C. Daboo
- March 2011
- IETF publication
Abstract
This specification describes how SRV records can be used to locate email services. [STANDARDS-TRACK]
Abstract
This specification describes how SRV records can be used to locate email services. [STANDARDS-TRACK]
RFC 5721: POP3 Support for UTF-8
Experimental- R. Gellens
- C. Newman
- February 2010
- IETF publication
- Applications Area
Abstract
This specification extends the Post Office Protocol version 3 (POP3) to support un-encoded international characters in user names, passwords, mail addresses, message headers, and protocol-level textual error strings. This document defines an Experimental Protocol for the Internet community.
- Obsoleted by RFC 6856
Abstract
This specification extends the Post Office Protocol version 3 (POP3) to support un-encoded international characters in user names, passwords, mail addresses, message headers, and protocol-level textual error strings. This document defines an Experimental Protocol for the Internet community.
RFC 5034: The Post Office Protocol (POP3) Simple Authentication and Security Layer (SASL) Authentication Mechanism
Proposed Standard- R. Siemborski
- A. Menon-Sen
- July 2007
- IETF publication
Abstract
This document defines a profile of the Simple Authentication and Security Layer (SASL) for the Post Office Protocol (POP3). This extension allows a POP3 client to indicate an authentication mechanism to the server, perform an authentication protocol exchange, and optionally negotiate a security layer for subsequent protocol interactions during this session.
This document seeks to consolidate the information related to POP3 AUTH into a single document. To this end, this document obsoletes and replaces RFC 1734, and updates the information contained in Section 6.3 of RFC 2449. [STANDARDS-TRACK]
Abstract
This document defines a profile of the Simple Authentication and Security Layer (SASL) for the Post Office Protocol (POP3). This extension allows a POP3 client to indicate an authentication mechanism to the server, perform an authentication protocol exchange, and optionally negotiate a security layer for subsequent protocol interactions during this session.
This document seeks to consolidate the information related to POP3 AUTH into a single document. To this end, this document obsoletes and replaces RFC 1734, and updates the information contained in Section 6.3 of RFC 2449. [STANDARDS-TRACK]
RFC 3656: The Mailbox Update (MUPDATE) Distributed Mailbox Database Protocol
Experimental- R. Siemborski
- December 2003
- Independent Stream publication
Abstract
As the demand for high-performance mail delivery agents increases, it becomes apparent that single-machine solutions are inadequate to the task, both because of capacity limits and that the failure of the single machine means a loss of mail delivery for all users. It is preferable to allow many machines to share the responsibility of mail delivery. The Mailbox Update (MUPDATE) protocol allows a group of Internet Message Access Protocol (IMAP) or Post Office Protocol - Version 3 (POP3) servers to function with a unified mailbox namespace. This document is intended to serve as a reference guide to that protocol.
Abstract
As the demand for high-performance mail delivery agents increases, it becomes apparent that single-machine solutions are inadequate to the task, both because of capacity limits and that the failure of the single machine means a loss of mail delivery for all users. It is preferable to allow many machines to share the responsibility of mail delivery. The Mailbox Update (MUPDATE) protocol allows a group of Internet Message Access Protocol (IMAP) or Post Office Protocol - Version 3 (POP3) servers to function with a unified mailbox namespace. This document is intended to serve as a reference guide to that protocol.
RFC 3206: The SYS and AUTH POP Response Codes
Proposed Standard- R. Gellens
- February 2002
- Legacy publication
Abstract
This memo proposes two response codes: SYS and AUTH, which enable clients to unambiguously determine an optimal response to an authentication failure. In addition, a new capability (AUTH-RESP-CODE) is defined. [STANDARDS-TRACK]
Abstract
This memo proposes two response codes: SYS and AUTH, which enable clients to unambiguously determine an optimal response to an authentication failure. In addition, a new capability (AUTH-RESP-CODE) is defined. [STANDARDS-TRACK]
RFC 2701: Nortel Networks Multi-link Multi-node PPP Bundle Discovery Protocol
Informational- G. Malkin
- September 1999
- IETF publication
- Internet Area
Abstract
This document specifies a standard way for Multi-link PPP to operate across multiple nodes. This memo provides information for the Internet community.
Abstract
This document specifies a standard way for Multi-link PPP to operate across multiple nodes. This memo provides information for the Internet community.
RFC 2595: Using TLS with IMAP, POP3 and ACAP
Proposed Standard- C. Newman
- June 1999
- Legacy publication
Abstract
Recognizing that such sites will desire simple password authentication in combination with TLS encryption, this specification defines the PLAIN SASL mechanism for use with protocols which lack a simple password authentication command such as ACAP and SMTP. [STANDARDS-TRACK]
Abstract
Recognizing that such sites will desire simple password authentication in combination with TLS encryption, this specification defines the PLAIN SASL mechanism for use with protocols which lack a simple password authentication command such as ACAP and SMTP. [STANDARDS-TRACK]
RFC 2449: POP3 Extension Mechanism
Proposed Standard- R. Gellens
- C. Newman
- L. Lundblade
- November 1998
- Legacy publication
Abstract
This memo updates RFC 1939 to define a mechanism to announce support for optional commands, extensions, and unconditional server behavior. [STANDARDS-TRACK]
Abstract
This memo updates RFC 1939 to define a mechanism to announce support for optional commands, extensions, and unconditional server behavior. [STANDARDS-TRACK]
RFC 2384: POP URL Scheme
Proposed Standard- R. Gellens
- August 1998
- Legacy publication
Abstract
This memo defines a URL scheme for referencing a POP mailbox. [STANDARDS-TRACK]
Abstract
This memo defines a URL scheme for referencing a POP mailbox. [STANDARDS-TRACK]
RFC 2195: IMAP/POP AUTHorize Extension for Simple Challenge/Response
Proposed Standard- J. Klensin
- R. Catoe
- P. Krumviede
- September 1997
- Legacy publication
Abstract
This specification provides a simple challenge-response authentication protocol that is suitable for use with IMAP4. [STANDARDS-TRACK]
Abstract
This specification provides a simple challenge-response authentication protocol that is suitable for use with IMAP4. [STANDARDS-TRACK]
RFC 2095: IMAP/POP AUTHorize Extension for Simple Challenge/Response
Proposed Standard- J. Klensin
- R. Catoe
- P. Krumviede
- January 1997
- Legacy publication
Abstract
This specification provides a simple challenge-response authentication protocol that is suitable for use with IMAP4. [STANDARDS-TRACK]
- Obsoleted by RFC 2195
Abstract
This specification provides a simple challenge-response authentication protocol that is suitable for use with IMAP4. [STANDARDS-TRACK]
RFC 1957: Some Observations on Implementations of the Post Office Protocol (POP3)
Informational- R. Nelson
- June 1996
- Legacy publication
Abstract
This memo provides information for the Internet community. This memo does not specify an Internet standard of any kind.
Abstract
This memo provides information for the Internet community. This memo does not specify an Internet standard of any kind.
RFC 1939: STD 53: Post Office Protocol - Version 3
Internet Standard- J. Myers
- M. Rose
- May 1996
- Legacy publication
Abstract
The Post Office Protocol - Version 3 (POP3) is intended to permit a workstation to dynamically access a maildrop on a server host in a useful fashion. [STANDARDS-TRACK]
Abstract
The Post Office Protocol - Version 3 (POP3) is intended to permit a workstation to dynamically access a maildrop on a server host in a useful fashion. [STANDARDS-TRACK]
RFC 1734: POP3 AUTHentication command
Proposed Standard- J. Myers
- December 1994
- Legacy publication
Abstract
This document describes the optional AUTH command, for indicating an authentication mechanism to the server, performing an authentication protocol exchange, and optionally negotiating a protection mechanism for subsequent protocol interactions. [STANDARDS-TRACK]
- Obsoleted by RFC 5034
Abstract
This document describes the optional AUTH command, for indicating an authentication mechanism to the server, performing an authentication protocol exchange, and optionally negotiating a protection mechanism for subsequent protocol interactions. [STANDARDS-TRACK]
RFC 1725: Post Office Protocol - Version 3
Internet Standard- J. Myers
- M. Rose
- November 1994
- Legacy publication
Abstract
This memo is a revision to RFC 1460, a Draft Standard. [STANDARDS-TRACK]
- Obsoleted by RFC 1939
Abstract
This memo is a revision to RFC 1460, a Draft Standard. [STANDARDS-TRACK]
RFC 1460: Post Office Protocol - Version 3
Draft Standard- M. Rose
- June 1993
- Legacy publication
Abstract
This memo is a revision to RFC 1225, a Draft Standard. [STANDARDS-TRACK]
- Obsoleted by RFC 1725
Abstract
This memo is a revision to RFC 1225, a Draft Standard. [STANDARDS-TRACK]
RFC 1225: Post Office Protocol: Version 3
Draft Standard- M.T. Rose
- May 1991
- Legacy publication
Abstract
This memo suggests a simple method for workstations to dynamically access mail from a mailbox server. [STANDARDS-TRACK]
- Obsoleted by RFC 1460
Abstract
This memo suggests a simple method for workstations to dynamically access mail from a mailbox server. [STANDARDS-TRACK]
RFC 1081: Post Office Protocol: Version 3
Unknown- M.T. Rose
- November 1988
- Legacy publication
Abstract
This memo suggests a simple method for workstations to dynamically access mail from a mailbox server. This RFC specifies a proposed protocol for the Internet community, and requests discussion and suggestions for improvements.
- Obsoleted by RFC 1225
Abstract
This memo suggests a simple method for workstations to dynamically access mail from a mailbox server. This RFC specifies a proposed protocol for the Internet community, and requests discussion and suggestions for improvements.
RFC 1082: Post Office Protocol: Version 3: Extended service offerings
Unknown- M.T. Rose
- November 1988
- Legacy publication
Abstract
This memo suggests a simple method for workstations to dynamically access mail from a discussion group server, as an extension to an earlier memo which dealt with dynamically accessing mail from a mailbox server using the Post Office Protocol - Version 3 (POP3). This RFC specifies a proposed protocol for the Internet community, and requests discussion and suggestions for improvements. All of the extensions described in this memo to the POP3 are OPTIONAL.
Abstract
This memo suggests a simple method for workstations to dynamically access mail from a discussion group server, as an extension to an earlier memo which dealt with dynamically accessing mail from a mailbox server using the Post Office Protocol - Version 3 (POP3). This RFC specifies a proposed protocol for the Internet community, and requests discussion and suggestions for improvements. All of the extensions described in this memo to the POP3 are OPTIONAL.
RFC 937: Post Office Protocol: Version 2
Historic- M. Butler
- J. Postel
- D. Chase
- J. Goldberger
- J.K. Reynolds
- February 1985
- Legacy publication
Abstract
This RFC suggests a simple method for workstations to dynamically access mail from a mailbox server. This RFC specifies a proposed protocol for the ARPA-Internet community, and requests discussion and suggestions for improvement. This memo is a revision of RFC-918.
Abstract
This RFC suggests a simple method for workstations to dynamically access mail from a mailbox server. This RFC specifies a proposed protocol for the ARPA-Internet community, and requests discussion and suggestions for improvement. This memo is a revision of RFC-918.
RFC 918: Post Office Protocol
Unknown- J.K. Reynolds
- October 1984
- Legacy publication
Abstract
This RFC suggests a simple method for workstations to dynamically access mail from a mailbox server. The intent of the Post Office Protocol (POP) is to allow a user's workstation to access mail from a mailbox server. It is expected that mail will be posted from the workstation to the mailbox server via the Simple Mail Transfer Protocol (SMTP). This RFC specifies a proposed protocol for the ARPA-Internet community, and requests discussion and suggestions for improvement. The status of this protocol is experimental, and this protocol is dependent upon TCP.
- Obsoleted by RFC 937
Abstract
This RFC suggests a simple method for workstations to dynamically access mail from a mailbox server. The intent of the Post Office Protocol (POP) is to allow a user's workstation to access mail from a mailbox server. It is expected that mail will be posted from the workstation to the mailbox server via the Simple Mail Transfer Protocol (SMTP). This RFC specifies a proposed protocol for the ARPA-Internet community, and requests discussion and suggestions for improvement. The status of this protocol is experimental, and this protocol is dependent upon TCP.
Subscribe to POP3
Get notified when:
- RFC changes to status, obsoleted by, updates, updated by, or subseries.
- New RFC added to this subject or below
- The subject was merged into another.