PPP

PPP (Point-to-Point Protocol) and its control protocols

PPP subjects:

PPP RFCs (112)

Display RFCs as
  • RFC 6431: Huawei Port Range Configuration Options for PPP IP Control Protocol (IPCP)

    Informational
  • Proposed Standard
  • RFC 5172: Negotiation for IPv6 Datagram Compression Using IPv6 Control Protocol

    Proposed Standard
  • RFC 5072: IP Version 6 over PPP

    Draft Standard
  • Proposed Standard
  • RFC 4334: Certificate Extensions and Attributes Supporting Authentication in Point-to-Point Protocol (PPP) and Wireless Local Area Networks (WLAN)

    Proposed Standard
  • RFC 4332: Cisco's Mobile IPv4 Host Configuration Extensions

    Informational
  • RFC 4045: Extensions to Support Efficient Carrying of Multicast Traffic in Layer-2 Tunneling Protocol (L2TP)

    Experimental
  • RFC 3931: Layer Two Tunneling Protocol - Version 3 (L2TPv3)

    Proposed Standard
  • RFC 3748: Extensible Authentication Protocol (EAP)

    Proposed Standard
  • RFC 3818: BCP 88: IANA Considerations for the Point-to-Point Protocol (PPP)

    Best Current Practice
  • RFC 3772: Point-to-Point Protocol (PPP) Vendor Protocol

    Proposed Standard
  • RFC 3770: Certificate Extensions and Attributes Supporting Authentication in Point-to-Point Protocol (PPP) and Wireless Local Area Networks (WLAN)

    Proposed Standard

      Obsoleted by RFC 4334

  • RFC 3544: IP Header Compression over PPP

    Proposed Standard
  • Proposed Standard
  • RFC 3573: Signalling of Modem-On-Hold status in Layer 2 Tunneling Protocol (L2TP)

    Proposed Standard
  • RFC 3518: Point-to-Point Protocol (PPP) Bridging Control Protocol (BCP)

    Proposed Standard
  • Proposed Standard
  • RFC 3438: BCP 68: Layer Two Tunneling Protocol (L2TP) Internet Assigned Numbers Authority (IANA) Considerations Update

    Best Current Practice
  • RFC 3336: PPP Over Asynchronous Transfer Mode Adaptation Layer 2 (AAL2)

    Proposed Standard
  • RFC 3337: Class Extensions for PPP over Asynchronous Transfer Mode Adaptation Layer 2

    Proposed Standard
  • RFC 3241: Robust Header Compression (ROHC) over PPP

    Proposed Standard
  • RFC 3255: Extending Point-to-Point Protocol (PPP) over Synchronous Optical NETwork/Synchronous Digital Hierarchy (SONET/SDH) with virtual concatenation, high order and low order payloads

    Proposed Standard
  • RFC 3186: MAPOS/PPP Tunneling mode

    Informational
  • RFC 3153: PPP Multiplexing

    Proposed Standard
  • RFC 3145: L2TP Disconnect Cause Information

    Proposed Standard
  • RFC 3078: Microsoft Point-To-Point Encryption (MPPE) Protocol

    Informational
  • RFC 3079: Deriving Keys for use with Microsoft Point-to-Point Encryption (MPPE)

    Informational
  • RFC 3017: XML DTD for Roaming Access Phone Book

    Proposed Standard
  • RFC 2878: PPP Bridging Control Protocol (BCP)

    Proposed Standard

      Obsoleted by RFC 3518

  • Experimental
  • RFC 2759: Microsoft PPP CHAP Extensions, Version 2

    Informational
  • RFC 2716: PPP EAP TLS Authentication Protocol

    Experimental

      Obsoleted by RFC 5216

  • Proposed Standard
  • RFC 2687: PPP in a Real-time Oriented HDLC-like Framing

    Proposed Standard
  • Informational
  • RFC 2661: Layer Two Tunneling Protocol "L2TP"

    Proposed Standard
  • RFC 2637: Point-to-Point Tunneling Protocol (PPTP)

    Informational
  • RFC 2607: Proxy Chaining and Policy Implementation in Roaming

    Informational
  • RFC 2615: PPP over SONET/SDH

    Proposed Standard
  • RFC 2509: IP Header Compression over PPP

    Proposed Standard

      Obsoleted by RFC 3544

  • RFC 2477: Criteria for Evaluating Roaming Protocols

    Informational
  • RFC 2484: PPP LCP Internationalization Configuration Option

    Proposed Standard
  • RFC 2486: The Network Access Identifier

    Proposed Standard

      Obsoleted by RFC 4282

  • RFC 2472: IP Version 6 over PPP

    Proposed Standard

      Obsoleted by RFC 5072, RFC 5172

  • RFC 2433: Microsoft PPP CHAP Extensions

    Informational
  • RFC 2419: The PPP DES Encryption Protocol, Version 2 (DESE-bis)

    Proposed Standard
  • RFC 2420: The PPP Triple-DES Encryption Protocol (3DESE)

    Proposed Standard
  • RFC 2363: PPP Over FUNI

    Proposed Standard
  • RFC 2364: PPP Over AAL5

    Proposed Standard
  • RFC 2284: PPP Extensible Authentication Protocol (EAP)

    Proposed Standard

      Obsoleted by RFC 3748

  • RFC 2290: Mobile-IPv4 Configuration Option for PPP IPCP

    Proposed Standard
  • RFC 2194: Review of Roaming Implementations

    Informational
  • RFC 2153: PPP Vendor Extensions

    Informational
  • RFC 2118: Microsoft Point-To-Point Compression (MPPC) Protocol

    Informational
  • RFC 2125: The PPP Bandwidth Allocation Protocol (BAP) / The PPP Bandwidth Allocation Control Protocol (BACP)

    Proposed Standard
  • RFC 2097: The PPP NetBIOS Frames Control Protocol (NBFCP)

    Proposed Standard
  • RFC 2023: IP Version 6 over PPP

    Proposed Standard

      Obsoleted by RFC 2472

  • RFC 2043: The PPP SNA Control Protocol (SNACP)

    Proposed Standard
  • RFC 1963: PPP Serial Data Transport Protocol (SDTP)

    Informational
  • RFC 1967: PPP LZS-DCP Compression Protocol (LZS-DCP)

    Informational
  • RFC 1974: PPP Stac LZS Compression Protocol

    Informational
  • Informational
  • RFC 1976: PPP for Data Compression in Data Circuit-Terminating Equipment (DCE)

    Informational
  • RFC 1977: PPP BSD Compression Protocol

    Informational
  • RFC 1978: PPP Predictor Compression Protocol

    Informational
  • RFC 1979: PPP Deflate Protocol

    Informational
  • Draft Standard
  • Draft Standard
  • RFC 1993: PPP Gandalf FZA Compression Protocol

    Informational
  • RFC 1994: PPP Challenge Handshake Authentication Protocol (CHAP)

    Draft Standard
  • RFC 1962: The PPP Compression Control Protocol (CCP)

    Proposed Standard
  • RFC 1968: The PPP Encryption Control Protocol (ECP)

    Proposed Standard
  • RFC 1969: The PPP DES Encryption Protocol (DESE)

    Informational

      Obsoleted by RFC 2419

  • RFC 1973: PPP in Frame Relay

    Proposed Standard
  • Informational
  • RFC 1915: BCP 3: Variance for The PPP Compression Control Protocol and The PPP Encryption Control Protocol

    Best Current Practice
  • RFC 1877: PPP Internet Protocol Control Protocol Extensions for Name Server Addresses

    Informational
  • RFC 1841: PPP Network Control Protocol for LAN Extension

    Informational
  • RFC 1762: The PPP DECnet Phase IV Control Protocol (DNCP)

    Draft Standard
  • RFC 1763: The PPP Banyan Vines Control Protocol (BVCP)

    Historic
  • RFC 1764: The PPP XNS IDP Control Protocol (XNSCP)

    Historic
  • Proposed Standard

      Obsoleted by RFC 1990

  • RFC 1661: STD 51: The Point-to-Point Protocol (PPP)

    Internet Standard
  • RFC 1662: STD 51: PPP in HDLC-like Framing

    Internet Standard
  • RFC 1663: PPP Reliable Transmission

    Proposed Standard
  • RFC 1638: PPP Bridging Control Protocol (BCP)

    Proposed Standard

      Obsoleted by RFC 2878

  • RFC 1618: PPP over ISDN

    Proposed Standard
  • RFC 1619: PPP over SONET/SDH

    Proposed Standard

      Obsoleted by RFC 2615

  • RFC 1598: PPP in X.25

    Proposed Standard
  • RFC 1570: PPP LCP Extensions

    Proposed Standard
  • RFC 1547: Requirements for an Internet Standard Point-to-Point Protocol

    Informational
  • RFC 1548: The Point-to-Point Protocol (PPP)

    Draft Standard

      Obsoleted by RFC 1661

  • RFC 1549: PPP in HDLC Framing

    Draft Standard

      Obsoleted by RFC 1662

  • RFC 1552: The PPP Internetworking Packet Exchange Control Protocol (IPXCP)

    Historic
  • RFC 1553: Compressing IPX Headers Over WAN Media (CIPX)

    Historic
  • Proposed Standard
  • RFC 1472: The Definitions of Managed Objects for the Security Protocols of the Point-to-Point Protocol

    Proposed Standard
  • RFC 1473: The Definitions of Managed Objects for the IP Network Control Protocol of the Point-to-Point Protocol

    Proposed Standard
  • RFC 1474: The Definitions of Managed Objects for the Bridge Network Control Protocol of the Point-to-Point Protocol

    Historic
  • RFC 1376: The PPP DECnet Phase IV Control Protocol (DNCP)

    Proposed Standard

      Obsoleted by RFC 1762

  • RFC 1377: The PPP OSI Network Layer Control Protocol (OSINLCP)

    Proposed Standard
  • RFC 1378: The PPP AppleTalk Control Protocol (ATCP)

    Historic
  • RFC 1334: PPP Authentication Protocols

    Proposed Standard

      Obsoleted by RFC 1994

  • RFC 1362: Novell IPX over Various WAN Media (IPXWAN)

    Informational

      Obsoleted by RFC 1634

  • Proposed Standard

      Obsoleted by RFC 1548

  • RFC 1332: The PPP Internet Protocol Control Protocol (IPCP)

    Proposed Standard
  • Proposed Standard

      Obsoleted by RFC 1989

  • RFC 1220: Point-to-Point Protocol extensions for bridging

    Proposed Standard

      Obsoleted by RFC 1638

  • Draft Standard

      Obsoleted by RFC 1331

  • RFC 1172: Point-to-Point Protocol (PPP) initial configuration options

    Proposed Standard

      Obsoleted by RFC 1331, RFC 1332

  • Proposed Standard

      Obsoleted by RFC 1171

Subscribe to PPP

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.