X.500

The X.500 directory service

X.500 RFCs (83)

Display RFCs as
  • RFC 5020: The Lightweight Directory Access Protocol (LDAP) entryDN Operational Attribute

    Proposed Standard
  • RFC 4510: Lightweight Directory Access Protocol (LDAP): Technical Specification Road Map

    Proposed Standard
  • RFC 4511: Lightweight Directory Access Protocol (LDAP): The Protocol

    Proposed Standard
  • RFC 4512: Lightweight Directory Access Protocol (LDAP): Directory Information Models

    Proposed Standard
  • RFC 4514: Lightweight Directory Access Protocol (LDAP): String Representation of Distinguished Names

    Proposed Standard
  • RFC 4515: Lightweight Directory Access Protocol (LDAP): String Representation of Search Filters

    Proposed Standard
  • RFC 4517: Lightweight Directory Access Protocol (LDAP): Syntaxes and Matching Rules

    Proposed Standard
  • RFC 4523: Lightweight Directory Access Protocol (LDAP) Schema Definitions for X.509 Certificates

    Proposed Standard
  • RFC 4524: COSINE LDAP/X.500 Schema

    Proposed Standard
  • RFC 4526: Lightweight Directory Access Protocol (LDAP) Absolute True and False Filters

    Proposed Standard
  • RFC 4530: Lightweight Directory Access Protocol (LDAP) entryUUID Operational Attribute

    Proposed Standard
  • RFC 3771: The Lightweight Directory Access Protocol (LDAP) Intermediate Response Message

    Proposed Standard

      Obsoleted by RFC 4510, RFC 4511

  • RFC 3727: ASN.1 Module Definition for the LDAP and X.500 Component Matching Rules

    Proposed Standard
  • RFC 3687: Lightweight Directory Access Protocol (LDAP) and X.500 Component Matching Rules

    Proposed Standard
  • RFC 3671: Collective Attributes in the Lightweight Directory Access Protocol (LDAP)

    Proposed Standard
  • RFC 3494: Lightweight Directory Access Protocol version 2 (LDAPv2) to Historic Status

    Informational
  • RFC 2377: Naming Plan for Internet Directory-Enabled Applications

    Informational
  • RFC 2378: The CCSO Nameserver (Ph) Architecture

    Informational
  • RFC 2293: Representing Tables and Subtrees in the X.500 Directory

    Proposed Standard
  • RFC 2294: Representing the O/R Address hierarchy in the X.500 Directory Information Tree

    Proposed Standard
  • RFC 2164: Use of an X.500/LDAP directory to support MIXER address mapping

    Proposed Standard
  • RFC 2247: Using Domains in LDAP/X.500 Distinguished Names

    Proposed Standard
  • RFC 2258: Internet Nomenclator Project

    Informational
  • RFC 2259: Simple Nomenclator Query Protocol (SNQP)

    Informational
  • RFC 2251: Lightweight Directory Access Protocol (v3)

    Proposed Standard

      Obsoleted by RFC 4510, RFC 4511, RFC 4512, RFC 4513

  • RFC 2252: Lightweight Directory Access Protocol (v3): Attribute Syntax Definitions

    Proposed Standard

      Obsoleted by RFC 4510, RFC 4512, RFC 4517, RFC 4523

  • RFC 2253: Lightweight Directory Access Protocol (v3): UTF-8 String Representation of Distinguished Names

    Proposed Standard

      Obsoleted by RFC 4510, RFC 4514

  • RFC 2254: The String Representation of LDAP Search Filters

    Proposed Standard

      Obsoleted by RFC 4510, RFC 4515

  • RFC 2256: A Summary of the X.500(96) User Schema for use with LDAPv3

    Proposed Standard

      Obsoleted by RFC 4510, RFC 4512, RFC 4517, RFC 4519, RFC 4523

  • RFC 2218: A Common Schema for the Internet White Pages Service

    Proposed Standard
  • RFC 2219: BCP 17: Use of DNS Aliases for Network Services

    Best Current Practice
  • RFC 2148: BCP 15: Deployment of the Internet White Pages Service

    Best Current Practice
  • RFC 2116: FYI 11: X.500 Implementations Catalog-96

    Informational
  • RFC 2120: Managing the X.500 Root Naming Context

    Experimental
  • RFC 2079: Definition of an X.500 Attribute Type and an Object Class to Hold Uniform Resource Identifiers (URIs)

    Proposed Standard
  • RFC 1943: Building an X.500 Directory Service in the US

    Informational
  • RFC 1823: The LDAP Application Program Interface

    Informational
  • RFC 1836: Representing the O/R Address hierarchy in the X.500 Directory Information Tree

    Experimental

      Obsoleted by RFC 2294

  • RFC 1837: Representing Tables and Subtrees in the X.500 Directory

    Experimental

      Obsoleted by RFC 2293

  • RFC 1838: Use of the X.500 Directory to support mapping between X.400 and RFC 822 Addresses

    Experimental

      Obsoleted by RFC 2164

  • RFC 1798: Connection-less Lightweight X.500 Directory Access Protocol

    Historic

      Obsoleted by RFC 3352

  • RFC 1801: MHS use of the X.500 Directory to support MHS Routing

    Experimental
  • RFC 1802: Introducing Project Long Bud: Internet Pilot Project for the Deployment of X.500 Directory Information in Support of X.400 Routing

    Informational
  • RFC 1803: Recommendations for an X.500 Production Directory Service

    Informational
  • RFC 1804: Schema Publishing in X.500 Directory

    Experimental
  • RFC 1777: Lightweight Directory Access Protocol

    Historic

      Obsoleted by RFC 3494

  • RFC 1778: The String Representation of Standard Attribute Syntaxes

    Historic

      Obsoleted by RFC 3494

  • RFC 1779: A String Representation of Distinguished Names

    Historic

      Obsoleted by RFC 2253, RFC 3494

  • RFC 1781: Using the OSI Directory to Achieve User Friendly Naming

    Historic

      Obsoleted by RFC 3494

  • RFC 1758: NADF Standing Documents: A Brief Overview

    Informational
  • RFC 1684: Introduction to White Pages Services based on X.500

    Informational
  • RFC 1617: Naming and Structuring Guidelines for X.500 Directory Pilots

    Informational
  • RFC 1632: A Revised Catalog of Available X.500 Implementations

    Informational

      Obsoleted by RFC 2116

  • RFC 1580: FYI 23: Guide to Network Resource Tools

    Informational
  • RFC 1608: Representing IP Information in the X.500 Directory

    Experimental
  • RFC 1609: Charting Networks in the X.500 Directory

    Experimental
  • RFC 1564: DSA Metrics (OSI-DS 34 (v3))

    Informational
  • RFC 1567: X.500 Directory Monitoring MIB

    Proposed Standard

      Obsoleted by RFC 2605

  • RFC 1558: A String Representation of LDAP Search Filters

    Informational

      Obsoleted by RFC 1960

  • RFC 1562: Naming Guidelines for the AARNet X.500 Directory Service

    Informational
  • RFC 1484: Using the OSI Directory to achieve User Friendly Naming (OSI-DS 24 (v1.2))

    Historic

      Obsoleted by RFC 1781, RFC 3494

  • RFC 1485: A String Representation of Distinguished Names (OSI-DS 23 (v5))

    Historic

      Obsoleted by RFC 1779, RFC 3494

  • RFC 1487: X.500 Lightweight Directory Access Protocol

    Historic

      Obsoleted by RFC 1777, RFC 3494

  • RFC 1488: The X.500 String Representation of Standard Attribute Syntaxes

    Proposed Standard

      Obsoleted by RFC 1778

  • RFC 1491: FYI 21: A Survey of Advanced Usages of X.500

    Informational
  • RFC 1417: NADF Standing Documents: A Brief Overview

    Informational

      Obsoleted by RFC 1758

  • RFC 1430: A Strategic Plan for Deploying an Internet X.500 Directory Service

    Informational
  • RFC 1431: DUA Metrics (OSI-DS 33 (v2))

    Informational
  • RFC 1384: Naming Guidelines for Directory Pilots

    Informational

      Obsoleted by RFC 1617

  • RFC 1373: Portable DUAs

    Informational
  • RFC 1330: Recommendations for the Phase I Deployment of OSI Directory Services (X.500) and OSI Message Handling Services (X.400) within the ESNET Community

    Informational
  • RFC 1308: FYI 13: Executive Introduction to Directory Services Using the X.500 Protocol

    Informational
  • RFC 1309: FYI 14: Technical Overview of Directory Services Using the X.500 Protocol

    Informational
  • RFC 1292: A Catalog of Available X.500 Implementations

    Informational

      Obsoleted by RFC 1632

  • RFC 1295: User Bill of Rights for entries and listings in the Public Directory

    Informational

      Obsoleted by RFC 1417

  • RFC 1274: The COSINE and Internet X.500 Schema

    Proposed Standard

      Obsoleted by RFC 4524

  • RFC 1275: Replication Requirements to provide an Internet Directory using X.500

    Informational
  • RFC 1276: Replication and Distributed Operations extensions to provide an Internet Directory using X.500

    Historic
  • RFC 1277: Encoding Network Addresses to Support Operation over Non-OSI Lower Layers

    Proposed Standard
  • RFC 1278: A string encoding of Presentation Address

    Informational
  • RFC 1279: X.500 and Domains

    Experimental
  • RFC 1255: A Naming Scheme for c=US

    Informational

      Obsoleted by RFC 1417

  • RFC 1249: DIXIE Protocol Specification

    Informational

Subscribe to X.500

Get notified when:

  • RFC changes to status, obsoleted by, updates, updated by, or subseries.
  • New RFC added to this subject or below
  • The subject was merged into another.